Issue with [OzzModz] TMDb TV Thread Starter 2.1.13 and Multi Prefix addon in xenforo

Subject Information

Category Name Troubleshooting \/ Bugs
TOPIC TITLE Issue with [OzzModz] TMDb TV Thread Starter 2.1.13 and Multi Prefix addon in xenforo
Thread starter heroo
Start date
Replies
Views
First message reaction score
LAST MESSAGE BY heroo

heroo

Registered
Paid
Local time
5:21 AM
Joined
Sep 29, 2021
Messages
8
Reaction score
1
Points
3
Age
20
Location
Berlin
Site Script
XenForo
Hi I have got an issue when I want to add a episode of an show I get this error:


Error: Call to undefined method SV\MultiPrefix\XF\Pub\Controller\Thread::getNewPostsReply() in src/addons/Snog/TV/XF/Pub/Controller/Thread.php at line 221
  1. Snog\TV\XF\Pub\Controller\Thread->actionAddReply() in src/XF/Mvc/Dispatcher.php at line 352
  2. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
  3. XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
  4. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
  5. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2345
  6. XF\App->run() in src/XF.php at line 512
  7. XF::runApp() in index.php at line 20

server error log:

I use the
[OzzModz] TMDb TV Thread Starter 2.1.13

TMDb Movie Thread Starter 2.1.3
[Xenbros] Custom Slider 2.0.0
Multi Prefix
XenForo Enhanced Search 2.2.1
XenForo Resource Manager 2.2.3
 
Last edited:

Admin

Staff member
Administrator
Registered
Local time
6:21 AM
Joined
Aug 21, 2015
Messages
13,425
Reaction score
57,157
Points
113
Age
48
Location
Egypt
Website
www.nullscripts.net
Site Script
XenForo
i think you must disable MultiPrefix addon and try
 

heroo

Registered
Paid
Local time
5:21 AM
Joined
Sep 29, 2021
Messages
8
Reaction score
1
Points
3
Age
20
Location
Berlin
Site Script
XenForo
thanks for the quick reply, but now I got a differnt error:

Error: Call to undefined method XFES\XF\Pub\Controller\Thread::getNewPostsReply() in src/addons/Snog/TV/XF/Pub/Controller/Thread.php at line 221
  1. Snog\TV\XF\Pub\Controller\Thread->actionAddReply() in src/XF/Mvc/Dispatcher.php at line 352
  2. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
  3. XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
  4. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
  5. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2345
  6. XF\App->run() in src/XF.php at line 512
  7. XF::runApp() in index.php at line 20


    serverlog:

 

heroo

Registered
Paid
Local time
5:21 AM
Joined
Sep 29, 2021
Messages
8
Reaction score
1
Points
3
Age
20
Location
Berlin
Site Script
XenForo
could it be that this addon is not very compatible with other addons?
 

Admin

Staff member
Administrator
Registered
Local time
6:21 AM
Joined
Aug 21, 2015
Messages
13,425
Reaction score
57,157
Points
113
Age
48
Location
Egypt
Website
www.nullscripts.net
Site Script
XenForo
i cant understand why your addons not compatible with that addon - now XenForo Enhanced Search need disable

anyway i suggest disable all addons and try that addon and try enable it one by one
 

heroo

Registered
Paid
Local time
5:21 AM
Joined
Sep 29, 2021
Messages
8
Reaction score
1
Points
3
Age
20
Location
Berlin
Site Script
XenForo
ok I will try that thanks^^
I also use xenforo 2.2.7
 
  • Like
Reactions: Admin

heroo

Registered
Paid
Local time
5:21 AM
Joined
Sep 29, 2021
Messages
8
Reaction score
1
Points
3
Age
20
Location
Berlin
Site Script
XenForo
I now disabeled most plugins and I now get this error


Error: Call to undefined method Snog\TV\XF\Pub\Controller\Thread::getNewPostsReply() in src\addons\Snog\TV\XF\Pub\Controller\Thread.php at line 221
  1. Snog\TV\XF\Pub\Controller\Thread->actionAddReply() in src\XF\Mvc\Dispatcher.php at line 352
  2. XF\Mvc\Dispatcher->dispatchClass() in src\XF\Mvc\Dispatcher.php at line 259
  3. XF\Mvc\Dispatcher->dispatchFromMatch() in src\XF\Mvc\Dispatcher.php at line 115
  4. XF\Mvc\Dispatcher->dispatchLoop() in src\XF\Mvc\Dispatcher.php at line 57
  5. XF\Mvc\Dispatcher->run() in src\XF\App.php at line 2345
  6. XF\App->run() in src\XF.php at line 512
  7. XF::runApp() in index.php at line 20


    Servererrorlog:
 

heroo

Registered
Paid
Local time
5:21 AM
Joined
Sep 29, 2021
Messages
8
Reaction score
1
Points
3
Age
20
Location
Berlin
Site Script
XenForo
I have found the issue: